Merge with bugfix-0.5
/debian/rules
blob:e3ed0753b7ae5092dfcc9bf68106ffcc8fa639ef -> blob:df1fb418e66b276c0f03c57cc4575e7df3b07954
--- debian/rules
+++ debian/rules
@@ -1,25 +1,42 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses cdbs. Originaly written by Robert Millan.
+# mp3togo debian/rules
+#
+# Simeon Veldstra 2006
+# Based on a file originaly written by Robert Millan.
# This file is public domain.
-DEB_TAR_SRCDIR := mp3togo-0.2.1
-DEB_AUTO_CLEANUP_RCS := yes
+#DEB_TAR_SRCDIR := mp3togo-0.2.1
+#DEB_AUTO_CLEANUP_RCS := yes
# Add here any variable or target overrides you need
-
+DEB_PYTHON_SYSTEM=pysupport
#include /usr/share/cdbs/1/class/makefile.mk
#include /usr/share/cdbs/1/rules/debhelper.mk
#include /usr/share/cdbs/1/rules/tarball.mk
#include /usr/share/cdbs/1/rules/simple-patchsys.mk
+# dh_pysupport
include /usr/share/cdbs/1/rules/buildcore.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
-DEB_ISNATIVE="True"
+#DEB_ISNATIVE="True"
build/mp3togo::
docbook-to-man debian/mp3togo.1.sgml > debian/mp3togo.1
dh_installman debian/mp3togo.1
+ # python-support:
+ #python setup.py build
+
+# python-support:
+#install:
+# python setup.py install --root=$(CURDIR)/debian/mp3togo
+#
+#binary-indep:
+# dh_pysupport
+# dh_installdeb
+
+